Wow

That OSX problem was really starting to turn me off of the Mac, I am glad I got it fixed… Even after a few minutes of using this machine now that it has been un-fucked, I am enjoying myself more than I have all along in OSX.

Here is an illustration of how much this problem was causing my user experience to suck:

  1. Open a gzipped .dmg file you just downloaded off the internet
  2. Wait 30-60 seconds for StuffIt to start and decompress the file
  3. Wait 30-60 seconds for Disk Copy to start and mount the disk image
  4. Copy the application inside the disk image to your drive and open it, wait another 30-60 seconds

Now, don’t get me wrong, occasionally (2 out of 10 times) there would be no delay, but it was definately in the minority of times… I was at the point where I would just leave all the applications I use running at all times so I didn’t have to deal with this bull.

Another time this was frustratingly annoying? Visit a web page in Chimera that has a username/password box. The browser loads the Keychain Management framework, which locks up the browser for 30-60 seconds while it waits so it can fetch the username and password you had it manage.

Perhaps some of you will understand why I haven’t been beaming about OSX all this time… ;)

4 thoughts on “Wow

  1. I own an iBook and I can’ seem to duplicate your troubles… everything takes a couple of seconds (from what you listed above). How much RAM do you have? What’s your processor? Sounds like an upgrade might be in order.

    1. Sorry, but this isn’t the case. I have a 733Mhz G4 “Quicksilver” PowerMac with 768M of ram. The system specs are wonderful, this was a problem with OSX, and according to the forums at MacFixIt, I am not alone in experiencing it… In fact, if other people were unable to reproduce the problem, products like Jaguar Cache Cleaner wouldn’t exist…

      In case you didn’t catch it, my previous entry describes how I corrected this problem…

Leave a Reply to sivart Cancel reply